ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • 백준 2206번 벽 부수고 이동하기(자바) - bfs##
    코딩테스트 2023. 1. 16. 16:00

    벽 부수고 이동하기 

     
    시간 제한메모리 제한제출정답맞힌 사람정답 비율
    2 초 192 MB 103585 25962 16176 22.712%

    문제

    N×M의 행렬로 표현되는 맵이 있다. 맵에서 0은 이동할 수 있는 곳을 나타내고, 1은 이동할 수 없는 벽이 있는 곳을 나타낸다. 당신은 (1, 1)에서 (N, M)의 위치까지 이동하려 하는데, 이때 최단 경로로 이동하려 한다. 최단경로는 맵에서 가장 적은 개수의 칸을 지나는 경로를 말하는데, 이때 시작하는 칸과 끝나는 칸도 포함해서 센다.

    만약에 이동하는 도중에 한 개의 벽을 부수고 이동하는 것이 좀 더 경로가 짧아진다면, 벽을 한 개 까지 부수고 이동하여도 된다.

    한 칸에서 이동할 수 있는 칸은 상하좌우로 인접한 칸이다.

    맵이 주어졌을 때, 최단 경로를 구해 내는 프로그램을 작성하시오.

    입력

    첫째 줄에 N(1 ≤ N ≤ 1,000), M(1 ≤ M ≤ 1,000)이 주어진다. 다음 N개의 줄에 M개의 숫자로 맵이 주어진다. (1, 1)과 (N, M)은 항상 0이라고 가정하자.

    출력

    첫째 줄에 최단 거리를 출력한다. 불가능할 때는 -1을 출력한다.

    예제 입력 1 복사

    6 4
    0100
    1110
    1000
    0000
    0111
    0000
    

    예제 출력 1 복사

    15

    예제 입력 2 복사

    4 4
    0111
    1111
    1111
    1110
    

    예제 출력 2 복사

    -1

    처음에는 모든 벽을 한 번씩 다 부숴서 경로를 모두 체크했는데 이렇게 했더니 시간초과가 발생했다.

    이 경우에는 bfs를 실행하면서 벽을 부수고 현재 칸에 도달한 경우와 벽을 부수지 않고 현재 칸에 도달한 경우를 모두 체크해주며 경로를 진행해야 한다.

    이때 visited배열을 2차원 배열로 해서 벽을 부순 경우와 안 부순 경우를 같이 체크하게 되면 경로가 중복되어 갈 수 있는 경우에도 갈 수 없는 경우로 체크되기 때문에 3차원 배열을 활용하여 벽을 부수고 visited 인 경우와 벽을 부수지 않고 visited인 경우를 따로 체크해줘야 한다.

    import java.io.BufferedReader;
    import java.io.InputStreamReader;
    import java.util.*;
    
    class Node {
        int x;
        int y;
        int cnt;
        boolean broken;
        Node(int x, int y, int cnt, boolean broken) {
            this.x = x;
            this.y = y;
            this.cnt = cnt;
            this.broken = broken;
        }
    
    }
    public class Main {
        static int n,m;
        static int[][] map;
        static boolean[][][] visited;
        static int[] dx = {-1,1,0,0};
        static int[] dy = {0,0,-1,1};
        static int answer;
        public static void main(String[] args) throws Exception{
            BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
            StringTokenizer st = new StringTokenizer(br.readLine());
            n = Integer.parseInt(st.nextToken());
            m = Integer.parseInt(st.nextToken());
    
            map = new int[n][m];
            visited = new boolean[n][m][2];
            for (int i = 0; i < n; i++) {
                String str = br.readLine();
                for (int j = 0; j < m; j++) {
                    map[i][j] =str.charAt(j) - '0';
                }
            }
            bfs();
            System.out.println(answer);
        }
    
    
        static void bfs() {
            Queue<Node> que = new LinkedList<>();
            que.offer(new Node(0,0,1, false));
            visited[0][0][0] = true;
            while (!que.isEmpty()) {
                Node now = que.poll();
                if (now.x == n-1 && now.y == m-1) {
                    answer = now.cnt;
                    return;
                }
                for (int i = 0; i < 4; i++) {
                    int nx = now.x + dx[i];
                    int ny = now.y + dy[i];
                    if (nx < 0 || ny < 0 || nx >= n || ny >= m) continue;
                    if (map[nx][ny] == 0) {  //벽이 아닌 경우
                        if (!now.broken && !visited[nx][ny][0]) {
                            visited[nx][ny][0] = true;
                            que.offer(new Node(nx,ny,now.cnt+1,false));
                        }
                        else if (now.broken && !visited[nx][ny][1]) {
                            visited[nx][ny][1] = true;
                            que.offer(new Node(nx,ny,now.cnt+1,true));
                        }
                    }
                    else if (map[nx][ny] == 1) {
                        if (!now.broken && !visited[nx][ny][1]) {
                            que.offer(new Node(nx,ny,now.cnt+1,true));
                            visited[nx][ny][1] = true;
                        }
                        //벽을 앞에서 부쉈다면 pass
                    }
                }
            }
            answer = -1;
    
        }
    }

    시간초과 코드 

    import java.io.BufferedReader;
    import java.io.InputStreamReader;
    import java.util.*;
    
    class Node {
        int x;
        int y;
        int cnt;
        Node(int x, int y, int cnt) {
            this.x = x;
            this.y = y;
            this.cnt = cnt;
        }
        Node(int x, int y) {
            this.x = x;
            this.y = y;
        }
    }
    public class Main {
        static int n,m;
        static int[][] map;
        static boolean[][] visited;
        static int[] dx = {-1,1,0,0};
        static int[] dy = {0,0,-1,1};
        static int answer = -1;
        static ArrayList<Node> list;
        public static void main(String[] args) throws Exception{
            BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
            StringTokenizer st = new StringTokenizer(br.readLine());
            n = Integer.parseInt(st.nextToken());
            m = Integer.parseInt(st.nextToken());
    
            map = new int[n][m];
            visited = new boolean[n][m];
            list = new ArrayList<>();
            for (int i = 0; i < n; i++) {
                String str = br.readLine();
                for (int j = 0; j < m; j++) {
                    map[i][j] =str.charAt(j) - '0';
                    if (map[i][j] == 1) list.add(new Node(i,j));
                }
            }
            bfs();
            for (int i = 0; i < list.size(); i++) {
                int a = list.get(i).x;
                int b = list.get(i).y;
                map[a][b] = 0;
                bfs();
                map[a][b] = 1;
            }
            System.out.println(answer);
        }
    
    
        static void bfs() {
            visited = new boolean[n][m];
            Queue<Node> que = new LinkedList<>();
            que.offer(new Node(0,0,1));
            visited[0][0] = true;
            while (!que.isEmpty()) {
                Node now = que.poll();
                if (now.x == n-1 && now.y == m-1) {
                    answer = answer != -1 ? Math.min(answer, now.cnt) : now.cnt;
                    return;
                }
                for (int i = 0; i < 4; i++) {
                    int nx = now.x + dx[i];
                    int ny = now.y + dy[i];
                    if (nx < 0 || ny < 0 || nx >= n || ny >= m) continue;
                    if (map[nx][ny] == 0 && !visited[nx][ny]) {
                        visited[nx][ny] = true;
                        que.offer(new Node(nx,ny,now.cnt+1));
                    }
                }
            }
    
        }
    }

     

     

    참고

    [Algorithm] BOJ 2206번 - 벽 부수고 이동하기 (Java) (tistory.com)

     

    [Algorithm] BOJ 2206번 - 벽 부수고 이동하기 (Java)

    안녕하세요 coding-knowjam입니다. 오늘은 알고리즘 문제를 풀어보겠습니다. 문제는 백준 온라인 저지에 있는 2206번 문제입니다. 문제에 대한 내용은 아래 링크를 통해서 읽어보시길 바라겠습니다.

    codingnojam.tistory.com

     

Designed by Tistory.