ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • 백준 12919번 A와 B 2 (자바) - bfs #
    코딩테스트 2022. 12. 28. 18:01

    A와 B 2 

     
    시간 제한메모리 제한제출정답맞힌 사람정답 비율
    2 초 512 MB 4851 1684 1347 34.153%

    문제

    수빈이는 A와 B로만 이루어진 영어 단어 존재한다는 사실에 놀랐다. 대표적인 예로 AB (Abdominal의 약자), BAA (양의 울음 소리), AA (용암의 종류), ABBA (스웨덴 팝 그룹)이 있다.

    이런 사실에 놀란 수빈이는 간단한 게임을 만들기로 했다. 두 문자열 S와 T가 주어졌을 때, S를 T로 바꾸는 게임이다. 문자열을 바꿀 때는 다음과 같은 두 가지 연산만 가능하다.

    • 문자열의 뒤에 A를 추가한다.
    • 문자열의 뒤에 B를 추가하고 문자열을 뒤집는다.

    주어진 조건을 이용해서 S를 T로 만들 수 있는지 없는지 알아내는 프로그램을 작성하시오. 

    입력

    첫째 줄에 S가 둘째 줄에 T가 주어진다. (1 ≤ S의 길이 ≤ 49, 2 ≤ T의 길이 ≤ 50, S의 길이 < T의 길이)

    출력

    S를 T로 바꿀 수 있으면 1을 없으면 0을 출력한다.

    예제 입력 1 복사

    A
    BABA
    

    예제 출력 1 복사

    1

    처음에는 s에서 t를 만드는 모든 방법을 탐색했으나 O(2^N)의 시간이 걸려서 메모리 초과가 발생했다.

    대신 t에서 한 문자씩 빼면서 s를 만들면 t의 문자 조건에 따라 불필요한 방법들을 제거할 수 있어 초과가 발생하지 않는다.

     

    성공 코드

    import java.util.LinkedList;
    import java.util.Queue;
    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            String s = sc.next();
            String t = sc.next();
            Queue<String> que = new LinkedList<>();
            que.offer(t);
            while (!que.isEmpty()) {
                String now = que.poll();
                if (now.equals(s)) {
                    System.out.println(1);
                    System.exit(0);
                }
                if (now.length() <= s.length()) continue;
                if (now.charAt(now.length()-1) == 'A') {
                    que.offer(now.substring(0, now.length()-1));
                }
                if (now.charAt(0) == 'B') {
                    StringBuffer sb = new StringBuffer(now.substring(1));
                    String reverse = sb.reverse().toString();
                    que.offer(reverse);
                }
    
            }
            System.out.println(0);
        }
    }

    메모리 초과 코드

    import java.util.LinkedList;
    import java.util.Queue;
    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            String s = sc.next();
            String t = sc.next();
            Queue<String> que = new LinkedList<>();
            que.offer(s);
            while (!que.isEmpty()) {
                String now = que.poll();
                if (now.equals(t)) {
                    System.out.println(1);
                    System.exit(0);
                }
                if (now.length() < t.length()) {
                    que.offer(now + 'A');
                    StringBuffer sb = new StringBuffer(now+'B');
                    String reverse = sb.reverse().toString();
                    que.offer(reverse);
                }
            }
            System.out.println(0);
        }
    }
Designed by Tistory.