ABOUT ME

-

Today
-
Yesterday
-
Total
-
  • 백준 10282번 해킹(자바) - 다익스트라
    코딩테스트 2022. 7. 27. 14:15

    해킹 성공다국어

    한국어   
    시간 제한메모리 제한제출정답맞힌 사람정답 비율
    2 초 256 MB 9855 3941 2799 38.853%

    문제

    최흉최악의 해커 yum3이 네트워크 시설의 한 컴퓨터를 해킹했다! 이제 서로에 의존하는 컴퓨터들은 점차 하나둘 전염되기 시작한다. 어떤 컴퓨터 a가 다른 컴퓨터 b에 의존한다면, b가 감염되면 그로부터 일정 시간 뒤 a도 감염되고 만다. 이때 b가 a를 의존하지 않는다면, a가 감염되더라도 b는 안전하다.

    최흉최악의 해커 yum3이 해킹한 컴퓨터 번호와 각 의존성이 주어질 때, 해킹당한 컴퓨터까지 포함하여 총 몇 대의 컴퓨터가 감염되며 그에 걸리는 시간이 얼마인지 구하는 프로그램을 작성하시오.

    입력

    첫째 줄에 테스트 케이스의 개수가 주어진다. 테스트 케이스의 개수는 최대 100개이다. 각 테스트 케이스는 다음과 같이 이루어져 있다.

    • 첫째 줄에 컴퓨터 개수 n, 의존성 개수 d, 해킹당한 컴퓨터의 번호 c가 주어진다(1 ≤ n ≤ 10,000, 1 ≤ d ≤ 100,000, 1 ≤ c ≤ n).
    • 이어서 d개의 줄에 각 의존성을 나타내는 정수 a, b, s가 주어진다(1 ≤ a, b ≤ n, a ≠ b, 0 ≤ s ≤ 1,000). 이는 컴퓨터 a가 컴퓨터 b를 의존하며, 컴퓨터 b가 감염되면 s초 후 컴퓨터 a도 감염됨을 뜻한다.

    각 테스트 케이스에서 같은 의존성 (a, b)가 두 번 이상 존재하지 않는다.

    출력

    각 테스트 케이스마다 한 줄에 걸쳐 총 감염되는 컴퓨터 수, 마지막 컴퓨터가 감염되기까지 걸리는 시간을 공백으로 구분지어 출력한다.

    예제 입력 1 복사

    2
    3 2 2
    2 1 5
    3 2 5
    3 3 1
    2 1 2
    3 1 8
    3 2 4
    

    예제 출력 1 복사

    2 5
    3 6

    풀이

    1. dist 배열을 max 값으로 초기화 한다.

    2. 해킹 당한 컴퓨터 c 부터 다른 컴퓨터들까지의 거리를 다익스트라 알고리즘을 통해 구한다.

    3. 만약 감염되지 않는 컴퓨터가 있다면 c부터 그 컴퓨터까지의 거리는 max 값일 것이므로 

    dist[i] == Integer.Max_Value가 아닌 경우 감염되는 컴퓨터로 보고 개수를 센다.

    4. 마지막 컴퓨터가 감염되는 시간은 dist배열에서 Integer.MaxValue를 제외한 가장 큰 값이다.

     

    import java.util.ArrayList;
    import java.util.Arrays;
    import java.util.PriorityQueue;
    import java.util.Scanner;
    
    class Node implements Comparable<Node>{
        int end;
        int cost;
        Node(int end, int cost) {
            this.end = end;
            this.cost = cost;
        }
    
        @Override
        public int compareTo(Node node) {
            if (this.cost < node.cost)
                return -1;
            return 1;
        }
    }
    public class Main {
        static ArrayList<ArrayList<Node>> graph;
        static int[] dist;
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            int t = sc.nextInt();
            while (t--> 0) {
                int n = sc.nextInt();
                int d = sc.nextInt();
                int c = sc.nextInt();
                graph = new ArrayList<>();
                dist = new int[n+1];
                for (int i = 0; i <= n; i++) {
                    graph.add(new ArrayList<>());
                }
                for (int i = 0; i < d; i++) {
                    int a = sc.nextInt();
                    int b = sc.nextInt();
                    int s = sc.nextInt();
                    graph.get(b).add(new Node(a, s));
                }
                Arrays.fill(dist, Integer.MAX_VALUE);
                dijkstra(c);
                int answer = 0;
                int max = 0;
                for (int i = 1; i <= n; i++) {
                    if (dist[i] != Integer.MAX_VALUE) {
                        answer++;
                        max = Math.max(max, dist[i]);
                    }
                }
                System.out.println(answer + " " + max);
            }
        }
        static void dijkstra(int c) {
            dist[c] = 0;
            PriorityQueue<Node> que = new PriorityQueue<>();
            que.offer(new Node(c, 0));
            while (!que.isEmpty()) {
                Node now = que.poll();
                if (dist[now.end] < now.cost) continue;
                for (int i = 0; i < graph.get(now.end).size(); i++) {
                    int cost = dist[now.end] + graph.get(now.end).get(i).cost;
                    if (cost < dist[ graph.get(now.end).get(i).end]) {
                        dist[graph.get(now.end).get(i).end] = cost;
                        que.offer(new Node(graph.get(now.end).get(i).end, cost));
                    }
                }
            }
        }
    }
Designed by Tistory.